1. piet14
  2. Back-up en upgrade
  3. vrijdag 01 februari 2019
Na het via Cpanel kiezen van de versie 7.2 van PHP i.p.v. 5.6 zie ik in mijn artikelen alleen maar code en kan ik niets meer normaal opslaan. Ook staat er het volgende:

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; plgSystemkSecure has a deprecated constructor in C:\xampp\htdocs\CDV\plugins\system\ksecure\ksecure.php on line 12

Geen plugin ksecure of System Secure kunnen vinden. Het weghalen van die tekst uit het betreffende script gaf evenmin resultaat.
Om de website werkbaar te houden moest ik dus via Cpanel terug naar 5.6 en nu heb ik op de laptop de laatste backup van Akeeba lokaal geïnstalleerd om daar verder te onderzoeken en te exprimenteren, maar hoe los ik dit op?
In een verslag de suggestie gelezen de foutcontrole op te schroeven maar na een uur zoeken nog niet gevonden waar dat moet. Ook ergens gelezen dat configuration gecontroleerd moet worden.

Kortom: Hoe kom in met PHP 7.2 weer tot een werkende website? Ik werk nu met Joomla 3.8.3.
Met vriendelijke groet
Piet
Geaccepteerde antwoord Pending Moderation
Er zal toch in Extensies - Plugins de plugin kSecure moeten zitten want die veroorzaakt deze melding.

Daarnaast, Joomla 3.8.3 nog? Dan loop je op dit moment zeven veiligheidupdates achter.
JDoc-vertaler, JPatch tester, JUG-organisator, moderator
Eigen site: https://www.hierbenikthuis.nl en van mijn loopgroep: https://www.loopgroep-arnhemia.nl
Assistant Team Leader van het Joomla Social Media Team
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 1
Geaccepteerde antwoord Pending Moderation
Dank voor de snelle reactie. ksecure moet er zijn, klinkt heel logisch. al tig keer gezocht, maar niet gevonden. Heb alles al een paar keer nagelopen maar zal het nog een keer doen.
Heb versie 9 ook gezien. Heb al een paar keer de site upgrades laten zoeken maar beweert bij te zijn. Zal het wel gaan forceren.
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 2
Patrick Smits
Gebruikersgroep regio Utrecht
Geaccepteerde antwoord Pending Moderation
Installeer ksecure opnieuw en deinstalleer hem dan eens. Vaak wil dit wel helpen. Denk namelijk dat hij met deinstalleren niet alles heeft verwijderd of dat hij niet op de juiste wijze in gedeinstalleerd,
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 3
Geaccepteerde antwoord Pending Moderation
Hallo Piet,
op de vraag
In een verslag de suggestie gelezen de foutcontrole op te schroeven maar na een uur zoeken nog niet gevonden waar dat moe

En lokaal kan je foutrapportage op maximum of ontwikkeling zetten
in administrator> System> Algemene instellingen tabblad server
En het zoeken doe je dat via administrator > extensies> beheren ?
het zou ook kunnen dat je het via phpmyadmin en dan bij jou database naam Structuur
xxxxj_extensions en dan vaak zo beetje in in de laatste rijen

ps
en als ik het goed heb is ksecure niet meer te downloaden in JED .
Bijlagen
lvda
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 4
Geaccepteerde antwoord Pending Moderation
Allen dank voor de bijdragen. Helaas heeft ook Murphy zich inmiddels gemeld!
Hoe ik ooit aan ksecure zou hebben moeten komen weet ik niet, maar er af komen lukt niet. Nergens te vinden. Ook herinstallatie en deïnstalleren is dus geen optie.
Inmiddels bleek dat ik een paar waarschuwingen had en ik heb op twee plaatsen een te krappe 2M in 128M gewijzigd. Toen ontdekte ik ook nog eens dat een paar automatische meldingen van o.a. een upgrade van Joomla waren uitgeschakeld. Daardoor was ik dus op 3.8.3. blijven hangen. (Ik heb nooit iets aan die instellingen gewijzigd natuurlijk)
Bij het lokaal upgraden van Joomla kreeg ik de volgende melding

Warning: require(/home/campvrij/public_html/libraries/vendor/composer/../symfony/polyfill-ctype/bootstrap.php): failed to open stream: No such file or directory in /home/campvrij/public_html/libraries/vendor/composer/autoload_real.php on line 66


Fatal error: require(): Failed opening required '/home/campvrij/public_html/libraries/vendor/composer/../symfony/polyfill-ctype/bootstrap.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/campvrij/public_html/libraries/vendor/composer/autoload_real.php on line 66 


Wanneer ik dan inlog op mijn site https://www.campingbridgedevrijbuiters.nl
zie ik tot mijn verwondering dezelfde boodschap. Het terugzetten van een gedownloade backup (en daar verwijderd) via Cpanel lukt dan weer niet want ik heb inmiddels ook nog mijn limiet overschreden. Morgen even wat meer ruimte regelen en een stap terug.

Ik heb de afgelopen week meer aan Joomla besteed dan het hele jaar daarvoor, maar het resultaat is omgekeerd evenredig! Wanneer de website weer in de lucht is zal ik kijken of iemand een oplossing heeft voor het probleem met "line 66" want daar is de zaak vooralsnog gestrand. Ik neem aan downloaden in kladblok aanpassen (hoe en wat?) en met FTP vervangen
Groet
Piet
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 5
Geaccepteerde antwoord Pending Moderation
Hallo Piet,

Ik dacht dat je lokaal aan testen was hoe te update dus vreemd dat dat de online site in de war raakt.
en weet je soms ook welke template de site gebruikt ?
lvda
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 6
Geaccepteerde antwoord Pending Moderation
Hallo Piet
En draai je live website nu op PHP 5.6.40
wat gebeurd er als je daar eens de php naar PHP 7.2 zet als de website is
upgrade naar recent kan dat het wel eens zijn.(even proberen lijkt me)
lvda
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 7
Geaccepteerde antwoord Pending Moderation
Akeeba heeft weer goed gewerkt. Template: OrdaSoftTemplate-BaseTemplate
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 8
Geaccepteerde antwoord Pending Moderation
Hallo Piet,
Het lijkt er nu op dat jou live site bestanden mogelijk ontbreken.
wat je kan proberen is om met een FTP programma
(een lokaal uit gepakte joomla 9.2 versie zonder de installation map)
de live site te overschrijven.
ps
en wat bedoel je precies met "Akeeba heeft weer goed gewerkt"
ik neem aan dat je de akeeba back-up ook via een FTP programma naar je pc haalt en of upload
en niet via de download link?.
Tevens is ook tijdens terug zetten van zo akeeba back-up van belang dat dan
de map waar je dat doet verder geheel leeg is behalve dus
de bestanden van akeeba kickstart en de bacj-up file
en tijdens de eerst stap kan je als in het welkoms scherm
(Things you should know about Akeeba Kickstart) weg klikt kan je kiezen bij 2 hoe
Select an extraction method ik kies altijd de stap Directly .
Maar ik neem aan dat je dat ook zo doet.
En dan eerst alle plug-ins en extensies laten zoeken naar updates voor je joomla gaat upgraden.
Bijlagen
lvda
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 9
Geaccepteerde antwoord Pending Moderation
Akeeba heeft inmiddels naar wens de backup weer netjes geïnstalleerd en ik heb dus lokaal weer beeld. Er ging kennelijk iets fout toen ik lokaal van 3.8.3 omhoog wilde.
Fatal error: require(): Failed opening required '/home/campvrij/public_html/libraries/vendor/composer/../symfony/polyfill-ctype/bootstrap.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/campvrij/public_html/libraries/vendor/composer/autoload_real.php on line 66 


Daar heb ik nog geen oplossing voor. Geen idee wat er op line 66 moet staan!
Ik kan nu (of morgen) natuurlijk alles (ex installer) met FTP naar de host brengen, maar dan is het nog steeds oud en inclusief die fout. Ik vrees echter dat elke actie nu even wordt geblokkeerd wegens de overschrijding.

Het leek me oorspronkelijk beter de oude versie die daar via Cpanel veiliggesteld was, weer terug te zetten, dan heb ik tenminste weer beeld op het web. Maar ook dat is met de oude Joomla versie!
Er moet nog heel wat gebeuren!
Fijne avond
Piet
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 10
Geaccepteerde antwoord Pending Moderation
Moet nog even bekennen dat ik Akeeba (tot nu toe) steeds gedownload heb (ook na lezing van de waarschuwing). Zal mijn leven beteren en voortaan FTP gebruiken.......
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 11
Geaccepteerde antwoord Pending Moderation
Fatal error: require(): Failed opening required '/home/campvrij/public_html/libraries/vendor/composer/../symfony/polyfill-ctype/bootstrap.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/campvrij/public_html/libraries/vendor/composer/autoload_real.php on line 66


Zoals Leen ook al zegt even het update pakket van Joomla downloaden en uitpakken (unzip).

De bestanden uit het uitgepakte zip bestand verplaatsen naar je probleem site lokaal dus en hiermee overschrijf je eventuele fouten en missende bestanden komen dan ook weer terug.

Succes ermee.

Groeten Ron
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 12
Geaccepteerde antwoord Pending Moderation
Hoi Leen en Ron,
Dank voor het meedenken en de suggesties. Ik ben inmiddels gruwelijk intensief bezig geweest, maar loop tegen allerlei foutmeldingen aan. Ik zal ze niet opsommen! Extra-complicatie: op deze (Spaanse) camping valt de WiFi en/of het licht wel eens uit.....
Op dit moment heb ik 3.9.2. lokaal werkend gekregen en probeer nu bij de host de 3.8.3 met FTP te vervangen. Als dat lukt ga ik via Cpanel de PHP instellen op 7.2. Dit even als tussenbericht. Wordt vervolgd. Groet
Piet
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 13
Geaccepteerde antwoord Pending Moderation
Hoi Piet,

maak van de lokale site (joomla 3.9.2) met akeeba een backup het backup bestand (formaat .JPA) zet je in de root je site incl kickstart.php bestand. Je root moet trouwens geheel leeg wezen om zo niet tegen problemen aan te lopen.

En maak ook even een nieuwe database aan bij je hosting wat die heb je ook nodig om je backup te installeren.

Succes ermee.

Groeten Ron :)
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 14
Geaccepteerde antwoord Pending Moderation
Hoi Ron,

Lokaal: Muteren van een artikel mislukt doordat opslaan etc niet werkt. Dus geforceerd afsluiten. Inchechen lukt niet meer. Nu een foutmelding,
Er heeft zich een fout voorgedaan.
500 Unknown column 'a.note' in 'field list'

Website: Na het bijwerken naar 3.9.2 via FTP en" Joomla core bestanden opnieuw installeren" zie ik

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; plgSystemkSecure has a deprecated constructor in C:\xampp\htdocs\CDV\plugins\system\ksecure\ksecure.php on line 12
Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\CDV\libraries\src\Http\Transport\CurlTransport.php on line 204

Weinig progressie.................................

Nu lokaal het volgende

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in C:\xampp\htdocs\CDV\libraries\fof\dispatcher\dispatcher.php on line 524

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in C:\xampp\htdocs\CDV\libraries\fof\dispatcher\dispatcher.php on line 529

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in C:\xampp\htdocs\CDV\libraries\fof\dispatcher\dispatcher.php on line 534

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in C:\xampp\htdocs\CDV\libraries\fof\dispatcher\dispatcher.php on line 539

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in C:\xampp\htdocs\CDV\libraries\fof\dispatcher\dispatcher.php on line 552

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in C:\xampp\htdocs\CDV\libraries\fof\dispatcher\dispatcher.php on line 561

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in C:\xampp\htdocs\CDV\libraries\fof\dispatcher\dispatcher.php on line 566

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in C:\xampp\htdocs\CDV\libraries\fof\dispatcher\dispatcher.php on line 580

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in C:\xampp\htdocs\CDV\libraries\fof\dispatcher\dispatcher.php on line 609

Groet
Piet
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 15
Geaccepteerde antwoord Pending Moderation
Lokaal weer naar 3.8.3 en updaten naar 3.9.2
Resultaat hieronder. ben er nog niet in geslaagd line 204 te vinden/muteren. Draai rondjes en kom niet vooruit.

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; plgSystemkSecure has a deprecated constructor in C:\xampp\htdocs\CDV\plugins\system\ksecure\ksecure.php on line 12

Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\CDV\libraries\src\Http\Transport\CurlTransport.php on line 204
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 16
Geaccepteerde antwoord Pending Moderation
Hallo Piet,

Welke PHP versie gebruik je nu in Xammp?

Begin eens weer overnieuw lokaal met je Joomla 3.8.3 site.

Doe eerst onderstaande handelingen voor dat je gaat update.

Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\CDV\libraries\src\Http\Transport\CurlTransport.php on line 204

Verhoog je Maximum execution time in je php.ini bestand van Xammp.
Op deze site vindt je uitleg over hoe en wat wanneer je het hebt gedaan start xammp in zijn geheel opnieuw op.

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; plgSystemkSecure has a deprecated constructor in C:\xampp\htdocs\CDV\plugins\system\ksecure\ksecure.php on line 12

In xammp moet je even naar localhost/phpmyadmin gaan en dan je database openen.
Daar zoek je op ksecure en alles wat er gevonden wordt verwijder je.
phpmyadmin-zoeken.jpg

Ga naar Extensies --> Beheren --> Updaten en klik op de button Vindt Updates is er iets gevonden installeer deze dan.
Daarna ga je naar Extensies --> Beheren --> Ontdekken en klik op de button Ontdekken is er wat gevonden installeer deze dan.
Nu ga je naar Extensies --> Beheren --> Database wanneer database structuur niet up to date is klik dan links bovenin op repareren.

Werkt je site nu nog goed? Geen fouten? Artikelen bewerken en Opslaan werkt ook nog?

Als alles goed werk maak van dit geheel een backup met akeeba.

Daarna kun je de update uitvoeren naar Joomla 3.9.2

Succes ermee.

Groeten Ron :)
Bijlagen
  1. 2 weken geleden
  2. Back-up en upgrade
  3. # 17
Geaccepteerde antwoord Pending Moderation
Hoi Ron,
Lokaal had ik PHP 7.3 met problemen en op de website 5.6 om het nog even zichtbaar en werkbaar te houden. Ik vloog van de ene foutmelding naar de andere, maar ik schoot niets op. Het door jou heel duidelijk beschreven stappenplan was dé oplossing, waarvoor zeer hartelijk dank. Dat had ik nodig. Lokaal heb ik nu een goed werkende versie. Met Akeeba een backup gemaakt en met FTP incl kickstart.php op de site gezet. Helaas heb ik de gegevens betr "database server host name" en "user name" thuis liggen. Morgen even bij de host navragen. Ik ben er bijna! DANK!
Groet
Piet
  1. een week geleden
  2. Back-up en upgrade
  3. # 18
Geaccepteerde antwoord Pending Moderation
Graag gedaan ;)

Succes ermee we horen het wel of het gelukt is.

Vriendelijke groeten,

Ron :)
  1. een week geleden
  2. Back-up en upgrade
  3. # 19
Geaccepteerde antwoord Pending Moderation
Toch nog dagen zitten tobben omdat ik geen toegang kreeg tot de database. Gelukkig had de host vanmorgen nog een tip ("Let er verder ook op dat u de aangemaakte database user toegang tot deze database geeft".) want ik had dus één "kleinigheidje" over het hoofd gezien...... Het was allemaal heel tijdrovend én leerzaam. De site is nu weer helemaal bij en alles doet het. Ik ga nu eindelijk onbekommerd van de Spaanse zon genieten. Nogmaals hartelijk dank. Adios. Piet
  1. een week geleden
  2. Back-up en upgrade
  3. # 20
  • Pagina :
  • 1


Er zijn nog geen reacties op dit bericht.
U mag echter niet reageren op dit bericht.
Sorry de discussie is momenteel gesloten. U kunt nu geen reactie plaatsen.