1. Lenny
  2. Gebruikersgroepen Nederland en België
  3. vrijdag 26 juli 2019
Joomla waarschuwt al een poos op mijn website dat ik de PHP versie moet updaten. Gebruik nu nog PHP 5.6.40
Webhost KeurigOnline antwoordt: De PHP-versie kan in dit geval nog steeds niet aangepast worden.
De door jou gebruikte Joomla versie gaat niet goed overweg met een php versie hoger dan 7.0
Dit komt mogelijk door een plug-in of door een thema dat hier niet goed mee overweg kan.
Ze adviseren om de website bouwer te raadplegen.

Hierdoor krijg ik SPAM mailtjes, twee verschillende soorten, minstens 6 binnen het uur.
Antwoord KeurigOnline: dit komt omdat de website zelf lijkt te spammen.
Vanuit de public_html (de website zelf) worden mails verstuurd naar verschillende vreemde adressen.
En nogmaals zeggen ze dat de website bouwer kan adviseren waar het precies aan ligt.

Wie kan mij helpen?
Lenny ter Velde
Geaccepteerde antwoord Pending Moderation
Hallo Lenny,

wanneer je de PHP versie verhoogt welke foutmelding(en) krijg je dan te zien?

En natuurlijk is de vraag om welke site gaat het? En welke Joomla versie?

Groetjes Ron :D
Geaccepteerde antwoord Pending Moderation
Hoi Ron,

Fijn dat je reageert.
Mijn Joomla versie is 3.9.10. Dat schijnt wel de meest recente versie te zijn.
De server gebruikt PHP 5.6.40.
Op mijn verzoek heeft de webhost, KeurigOnline, de PHP versie afgelopen januari verhoogt. Dit was de eerste keer.
Een week later kwam ik er zelf achter dat de website helemaal niet meer toegankelijk was. Vraag me dus af of ze wel een foutmelding kregen. Of ze waren gewoon onzorgvuldig.
Ik heb het ze verteld en toen kwamen ze dus met die antwoorden. Ze hebben de site toen teruggezet naar de oorspronkelijke versie , zodat je er weer op kon komen.
Een paar weken geleden kwam er een nog hogere PHP versie uit. Heb ze toen toch maar nog een keer gevraagd om te updaten, maar dat lukt dus niet.
Heb ze vanmorgen een mail gestuurd of ze ook een foutmelding hadden gezien, maar heb nog geen antwoord.
Het gaat om: http://www.sanchara.nl

Groetjes, Lenny
Lenny ter Velde
Geaccepteerde antwoord Pending Moderation
Hallo Lenny,

ik zie dat je directadmin gebruikt dan kan je toch zelf je PHP versie wijzigen? Of is dat uitgeschakeld door je hosting?

Groeten Ron
Geaccepteerde antwoord Pending Moderation
Hoi Ron,

Dat klopt ik heb directe toegang. En al heb ik de website zelf gemaakt, ik ben niet een uitblinker op dat gebied.
Heb later wel gekeken en idd gezien dat ik dat zelf ook kan doen. Heb de update toen ook een keer gedaan. En weer was de website daarna uit de lucht.
Maar het maakt niet zoveel uit of zij het doen of dat ik het doe. Als de PHP versie wordt verhoogd, dan ontstaat er dus een probleem.
Na heel wat heen en weer gemail antwoordde hij uiteindelijk dit:

Beste Lenny, de door jou gebruikte Joomla versie gaat niet goed overweg met een php versie hoger dan 7.0
Dit komt mogelijk door een plug-in of door een thema dat hier niet goed mee overweg kan.
Om te weten waar dit precies door komt zal u de website bouwer kunnen raad plegen deze kan voor je uit zoeken waar het precies niet aan ligt.

Groetjes, Lenny
Lenny ter Velde
Geaccepteerde antwoord Pending Moderation
Hoi Lenny,

wat je hebt beste kan doen is het volgende.

Login in de backend van je site.
Ga naar --> Systeem --> Algemene Instellingen --> Tab Server
Zet Foutrapportage op Maximum en sla het geheel op en desnoods cache website en browser opschonen.

Dan log je in in Direcadmin en verhoog je de PHP versie naar 7.2 en sla dit geheel ook weer op.
Navigeer dan naar je site en kijk of er nu een foutmelding(en) komt te staan zo ja deel deze dan met ons.

Succes ermee.

Groeten Ron :)
Geaccepteerde antwoord Pending Moderation
Hoi Ron,

Dank je dat je hier zo'n aandacht aan besteedt. Ik ga het proberen.

Groetjes, Lenny
Lenny ter Velde
Geaccepteerde antwoord Pending Moderation
Dag Ron,

Heb de foutreportage op maximum gezet.
InDirectAdm heb ik twee keuzes om de PHP op te hogen. Naar 7.1 of 7.3.
Ik heb beide uitgeprobeerd en krijg bij allebei de bijgaande foutmelding (zie att.) als ik erna naar de website wil gaan.
Als ik de PHP vervolgens weer terug zet op 5.6 kan de website weer normaal bezocht worden.
Hij staat nu op PHP 7.3.

Groetjes, Lenny
Bijlagen
Lenny ter Velde
Geaccepteerde antwoord Pending Moderation
Moguh Lenny,

ik zie dat je nog wel in je backend kan komen! Dus probeer eens een andere template uit dus een standaard template van joomla zelf in je frontend.

Zo kun je uitsluiten of het probleem in je template zit.

Succes ermee.

Groeten Ron :)
Geaccepteerde antwoord Pending Moderation
Morgen,

Jij bent snel! Ik ga er mee aan de slag.

Groetjes, Lenny
Lenny ter Velde
Geaccepteerde antwoord Pending Moderation
Ron, heb via DirectAdm, Templates / stijlen Protostar op default gezet.
10 minuten gewacht. Resultaat blijft hetzelfde.

Groetjes, Lenny
Lenny ter Velde
Geaccepteerde antwoord Pending Moderation
Hoi Lenny,

nu moet je gaan kijken of er extensies zijn die je zelf hebt geïnstalleerd misschien verouderd zijn.

Kom je er echt niet uit dan mag je me een pm sturen met inlog gegevens van je site.

Groetjes Ron
Geaccepteerde antwoord Pending Moderation
Ron, hij staat nu op 7.1
Lenny ter Velde
Geaccepteerde antwoord Pending Moderation
Ron, hij staat nu op 7.1


Nu geeft de hele site 503 melding! Verlaag hem maar weer naar PHP 5.6.4

Groeten Ron
Geaccepteerde antwoord Pending Moderation
Allright
Lenny ter Velde
Geaccepteerde antwoord Pending Moderation
Hoi Ron,

Misschien heb je het al gezien. Maar als je nu op de site gaat, staat er een stukje programmeertekst waar jij meer van zult begrijpen dan ik denk ik.
Het begint met deprecated, enz.

Groetjes, Lenny
Lenny ter Velde
Geaccepteerde antwoord Pending Moderation
Hallo Lenny,

ik heb in je backend mogen kijken maar er is meer aan de hand.

Heb akeeba backup geinstalleerd maar een backup maken wil niet, database repair werkt ook niet enz enz De site blijft maar laden.

Zie ook dat er heel veel gebruikers zijn dat is de bedoeling denk ik ook niet.

Groeten Ron :)
Geaccepteerde antwoord Pending Moderation
Hoi Ron,

Nou, het is niet om vrolijk van te worden iig. De site lijkt toch echt stevig gehackt te zijn.
Ik heb in de bijlage de 2 soorten spammailtjes gezet. Van elk krijg ik er zo'n 7 stuks per uur.
Bij de eerste viel me op dat ze me als geadresseerde Sanch73 noemen. Dat is mijn gebruikersnaam voor de DirectAdm. Verder kan ik deze ook niet als ongewenste mail aanmerken in Outlook.
Dus je begrijpt, het geluid voor meldingen van m'n telefoon staat nu uit.
In het tweede soort spammailtje wordt elke keer een ander (email)adres genoemd.
Het lijkt er niet op dat de beveiliging voor mijn huidige PHP versie bijzonder lang is ondersteund.
Bijlagen
Lenny ter Velde
Geaccepteerde antwoord Pending Moderation
Volgens mij zijn het geen spam e-mails, maar krijg je mail omdat je de gebruikersregistratie aan hebt staan.
Geaccepteerde antwoord Pending Moderation
Volgens mij zijn het geen spam e-mails, maar krijg je mail omdat je de gebruikersregistratie aan hebt staan.


Hoi Margriet,

ik mocht in de backend van Lenny kijken en je hebt gelijkt die stond nog aan.

Groeten Ron
Geaccepteerde antwoord Pending Moderation
Het template probleem is verholpen dus de site draait ook op PHP 7.3

In de index.php van template staat onderstaande code.
<?php $menu = JSite::getMenu(); ?>


Vervangen door.
<?php $menu = JFactory::getApplication()->getMenu(); ?>


Website werkt niet met PHP 7.1 terwijl een kopie van haar site op mijn server bij Vimexx alles wel werkt ook met PHP 7.1

Ook een simpele back-up met akeeba backup maken, of een database repair werkt ook niet en bij Vimexx wel.

Dus meer problemen maar dat komt door hosting server en niet joomla dus ze moet contact opnemen met hosting.

Vriendelijke groeten,

Ron :)
  • Pagina :
  • 1
  • 2


Er zijn nog geen reacties op dit bericht.
Wees een van de eersten om op dit bericht te reageren!