1. pgmjans
  2. Gebruikersgroepen Nederland en België
  3. maandag 09 september 2019
Hallo, ik heb een vraag mbt het verhogen van de php versie. Ik weet niet of ik de vraag op het juiste forum vraag.
Als ik de php versie verhoog (nu is dit php 6.5) naar 7... dan werkt de website niet meer. Er is een extensie geïnstalleerd maar die wordt niet meer ondersteund. De makers van de extensie zijn er nl mee gestopt helaas. Ik weet nu niet waar de fout zit. Hoe kom ik hier achter en nog meer de vraag is hoe los ik dat op dat de website wel naar een hogere php versie kan worden overgezet?
Ik heb een kopie van de website staan op bertjanssens.nl. Hiermee kan ik testen...
MvG
Peter
Geaccepteerde antwoord
Geaccepteerde antwoord Pending Moderation
Ik heb mogen kijken in de site van Peter en ben tot een gedeeltelijk oplossing gekomen ;)

In het bestand view.html.php terug te vinden in components/com_hoteldirectory/views/strutturelist heb ik een aanpassing gedaan.

Onderstaande code:
$this->menus		= JSite::getMenu();

Veranderd in:
$this->menus		= JFactory::getApplication()->getMenu();

Hou er rekening mee dat dit een gedeeltelijk oplossing is!!

Want van de extensie komen geen updates meer uit en gaat dus niet met de tijd mee en is dus verouderd.
Een verouderde extensie kan voor veiligheid problemen geven!

Dus ik adviseer je om wel opzoek te gaan naar een nieuwe extensie die het soortgelijk voor je doet.

Succes met de site.

Groeten Ron :)
Geaccepteerde antwoord Pending Moderation
Middag,

er stond ook nog een view.html.php in components/com_hoteldirectory/views/struttura met de zelfde code op lijn 31.

Dus code aangepast en dat werkt heb al PHP gecheckt op foute code en kan geen een vinden.

Groeten Ron :)
  • Pagina :
  • 1
  • 2


Er zijn nog geen reacties op dit bericht.
Wees een van de eersten om op dit bericht te reageren!