1. hanHmaas
  2. de Cock
  3. Installeren
  4. zondag 30 december 2018
Na jaren van installeren, werken en upgraden met/van Joomla! moet ik op mijn Win 10 laptop Joomla! in MAMP installeren. Maar wat ik ook doe, tijdens de installatie van Joomla! krijg ik: Foutnummer: Could not connect to MySQL server. Lezen, forums doorzoeken, een oplossing vind ik niet.
Wie heeft voor mij een idee in welke richting ik de oplossing zoek?
Bij voorbaat dank voor je reactie.
Han
Geaccepteerde antwoord Pending Moderation
Hallo Han,

Heb je gekeken of of bij configuration.php(indien bestaande installatie is)
Bij mijn Mamp is database benaderen dus user en paswoord zie code.
op

public $user = 'root';
public $password = 'root';

en wat ook vaak voorkomt in windows 10 is dat skype als die draaid wel eens de port 80 gebruikt
dus dan eventueel die uitzetten of andere poort nummer kiezen in mamp
en anders ook eens kijken bij windows 10 systeembeheer of er geen server al draaid
Bijlagen
lvda
  1. meer dan een maand geleden
  2. Installeren
  3. # 1
Geaccepteerde antwoord Pending Moderation
Hallo Leen,
Het poort-probleem is mij wel bekend, dus de instellingen zijn voor apache=8888 en voor MySQL=8889.
Het gaat echter mis tijdens de installatie van Joomla!, bij: "Database configuratie".
Naam host: localhost
Gebruikersnaam: root
Wachtwoord: of leeg gelaten, of een zelfgemaakte ingevuld, of zelfs in phpMyAdmin een wachtwoord aangemaakt en hier ingevuld.
Telkens de hele installatie van MAMP incl Joomla! gewist. Zo onderhand een tijdrovende klus. Terwijl het zo simpel moet lopen, toch?
  1. meer dan een maand geleden
  2. Installeren
  3. # 2
Geaccepteerde antwoord Pending Moderation
Hallo Han,

is de installatie van mamp wel goed gegaan dan.
en draaid mamp wel goed dus ik bedoel krijg je kruisje in apache server en mysql server
en geeft hij groen bij stop server ? en als je op open start page drukt werkt dat ook .
en kan je dan naar phpmyadmin komen om een data base te maken.?
Bijlagen
lvda
  1. meer dan een maand geleden
  2. Installeren
  3. # 3
Geaccepteerde antwoord Pending Moderation
Hallo Leen,
MAMP draait goed. In phpMyAdmin heb ik een nieuwe database aangemaakt vooraf aan de installatie van Joomla! Eerst zonder gebruikers wachtwoord, later (na weer een hele nieuwe schone installatie van MAMP) met. En dat verandert de situatie niet.
  1. meer dan een maand geleden
  2. Installeren
  3. # 4
Geaccepteerde antwoord Pending Moderation
Hallo Han,

Heel apart ik had vanmorgen bij mezelf nog een test gedaan en kon zo een schone joomal installeren op mijn pc.
Krijg je alleen maar de melding Could not connect to MySQL server ? of meer
En mag ik eens weten heb je map buiten de Windows mappen geïnstalleerd dus niet in programma files
of documenten ?
en welke Mamp versie heb je geïnstalleerd
lvda
  1. meer dan een maand geleden
  2. Installeren
  3. # 5
Geaccepteerde antwoord Pending Moderation
Hallo Han,

Nog even extra vraagje omdat ik er nu aan denk dat je mamp opnieuw heb geïnstalleerd
heb je dan ook aangedacht om de php instellingen van de gekozen php versie aan te passen
zodat je er niet te snel wordt uit gegooid etc
zoals bv e:\MAMP\conf\php7.2.10\

max_execution_time = 630 ; Maximum execution time of each script, in seconds
max_input_time = 600 ; Maximum amount of time each script may spend parsing request data
;max_input_nesting_level = 64 ; Maximum input variable nesting level
memory_limit = 528M ; Maximum amount of memory a script may consume (128MB)
; Maximum size of POST data that PHP will accept.
post_max_size = 128M
; Maximum allowed size for uploaded files.
upload_max_filesize = 128M
; Maximum time (in seconds) for connect timeout. -1 means no limit
mysql.connect_timeout = 160


lvda
  1. meer dan een maand geleden
  2. Installeren
  3. # 6
Geaccepteerde antwoord Pending Moderation
Hallo Leen,
Nog in het oude jaar kwam ik er achter dat "ergens" op de laptop nog een oude xampp geïnstalleerd stond. Ben maar weer gaan deïnstalleren (die xampp en de MAMP met alles d'rop en d'ran). En opnieuw de allerlaatste MAMP ver. 4.1 en Joomla! ver. 3.9.1 geïnstalleerd.
Standaard wordt MAMP door mij gezet in: "C:/MAMP/htdocs/joomla"
De foutmelding is telkens:
FOUT Er kan geen verbinding gemaakt worden met de database. Foutnummer: Could not connect to MySQL server.

Een paar van jouw, bovenstaande aanpassingen van php.ini was ik al zoekende tegen gekomen. Nu ga ik ze allen even aanpassen....
Nee, de installatie van Joomla! stopt weer bij de: "Database configuratie" pagina.
  1. meer dan een maand geleden
  2. Installeren
  3. # 7
Geaccepteerde antwoord Pending Moderation
Hallo Han,

Ik heb het ook uit getest en de nieuwste versie start hier maar 1 keer de mysql server goed op
bij een 2 poging start de mysql server niet meer.
Ik vind op internet meer problemen daarover maar geen oplossing nog.
Maar met mijn hier ouder versieouder versie map 3.3.1 werkt het allemaal nog wel alleen zijn de php versies nog net geen php 7.2
ps
ik blijf nog poosje wel de nieuwste versie map 4.1 uitproberen misschien kan toch nog iets ontdekken waarom
dit niet wil lukken
lvda
  1. meer dan een maand geleden
  2. Installeren
  3. # 8
Geaccepteerde antwoord Pending Moderation
Hallo Leen,
Zéér bedankt dat je tussen de oliebollen door, met mijn probleem bezig bent geweest. Ik laat MAMP maar even voor wat het is en zal proberen toch verder te komen met XAMPP.
Han
  1. meer dan een maand geleden
  2. Installeren
  3. # 9
Geaccepteerde antwoord Pending Moderation
Hoi Han,

Misschien heb je wat aan deze video: https://www.youtube.com/watch?v=N6ENnaRotmo
Neem hier even de tijd voor, dan zal het duidelijk worden.
Tevens ook nog even een duidelijke handleiding voor je: https://www.shaileshjha.com/step-by-step-how-to-install-xampp-in-windows-and-fix-port-issues-for-apache-server/
Foto- & Webstudio Digitaal ICT (René Schouten)
Wij kunnen voor u Webdesign & Webhosting Verzorgen
Geregistreerd Partner van Vimexx "Dé best beoordeelde Hoster van Nederland"
"Webdesign & Webhosting voor Low Budget Prijzen"
  1. meer dan een maand geleden
  2. Installeren
  3. # 10
Geaccepteerde antwoord Pending Moderation
Hallo Leen,
Inmiddels heb ik na weer gedoe, XAMPP draaien. Met name dit artikel:
https://superuser.com/questions/948506/wampserver-issues-after-windows-10-upgrade
heeft de doorslag gegeven. Het ging dus over Visual C++.
Groet,
Han.
  1. meer dan een maand geleden
  2. Installeren
  3. # 11
Geaccepteerde antwoord Pending Moderation
Hallo Han,

Dank voor terug koppelen oorzaak waarom het bij jou niet lukte.
Aan de Visual C++ had ik niet aan gedacht omdat hij bij mijn eigen test steeds
met installeren van Wamp of andere dingen daar melding van maakt en
ik dan kon kiezen om het te laten installeren maar zo zie niks is het zelfde
maar fijn dat probleem opgelost is
lvda
  1. meer dan een maand geleden
  2. Installeren
  3. # 12
  • Pagina :
  • 1


Er zijn nog geen reacties op dit bericht.
U mag echter niet reageren op dit bericht.
Sorry de discussie is momenteel gesloten. U kunt nu geen reactie plaatsen.