zaterdag 12 januari 2019
  4.5K Visits
Joomla! 3.9.1

Ik ben er zojuist achtergekomen, dat de Google Authenticator instellingen niet werken.

Plugin is ingeschakeld alleen voor de beheerders gedeelte.

Bij gebruikers > beheren > gebruikers kies ik de de hoofd account.

  • Tabblad Authenticatiemethode in twee stapen
  • Keuze "Authenticatiemethode Google Authenticator "
  • Ipad keuze QR code scannen in Google Authenticator, voer ik in bij Beveiligingscode.
  • Na het opslaan, worden de ingevoerde code niet opgeslagen.

Ook wordt de nieuwe gegevens niet opgeslagen in de configuration.php die ik een chmod had gegeven 777.
meer dan een maand geleden
·
#18699
Voor zover ik weet klopt dit. De code wordt telkens opnieuw aangeboden en de kracht is dat er geen codes worden opgeslagen, waardoor hacking niet meer mogelijk is.
meer dan een maand geleden
·
#18700
Ik begrijp dat de code opnieuw wordt aangeboden.

Echter wordt in de adminpanel niets opgeslagen, en alles blijft het zelfde nadien dat er geen Authenticator is ingeschakeld.

Authenticator kan men dus niet inschakelen.
meer dan een maand geleden
·
#18701
In het admin panel wordt ook niets opgeslagen, weet niet wat je daarmee bedoeld. Heb je voorbeelden, screenshots ...

Heb je onderstaande gedaan?
Als u Google Authenticator wilt gebruiken, schakel dan authenticatie in twee stappen in voor uw Google-account. Ga naar http://www.google.com/2step om aan de slag te gaan.
meer dan een maand geleden
·
#18702
Heb je al deze stappen doorlopen:

Hier
meer dan een maand geleden
·
#18703
Zal het wellicht wel verkeerd beschrijven.

je hebt een drop down menu, de tweede keuze inschakelen van de authenticatie mogelijkheid.
Ik kan met de Ipad de QR code verkrijgen, die ik invul in het laatste veld die op die pagina staat.
Zodra ik alles op sla, is er niets ingesteld, en de keuzemenu staat weer op maak uw keuze om de authenticatie in te schakelen.
Ook gebeurd dat met de sleutel code die in de zelfde tabblad wordt vermeld dat er niets staat ingesteld.

Ik heb eerder nog nooit problemen gehad met de instellingen van een 2 weg authenticatie van google, nu dus wel en ik wil weten waarom dat nu ineens wel het geval is.
meer dan een maand geleden
·
#18704
Is de plug-in wel ingeschakeld? Staat namelijk standaard uit.
meer dan een maand geleden
·
#18705
Zodra de plugin niet aan staat, kan men ook niet bij Tabblad Authenticatiemethode de keuzemenu kunnen gebruiken en of dat de tabblad dan zichtbaar wordt
meer dan een maand geleden
·
#18706
Dus je krijgt dit niet te zien na opslaan? Zie afbeelding.
meer dan een maand geleden
·
#18707
Zie foto's
meer dan een maand geleden
·
#18708
Heb je verder in de backend problemen met opslaan?
meer dan een maand geleden
·
#18709
Nee, verder heb ik geen problemen met het opslaan van gegevens zoals bij "algemene instellingen" en of met artikelen.

Alleen dus met Google Authenticator instellingen
meer dan een maand geleden
·
#18710
Geen idee wat er dan verkeerd gaat.
meer dan een maand geleden
·
#18711
Juist ik dus ook niet, gezien dat het altijd heeft gewerkt.

Ik gebruik de juiste app van google, de juiste code die je scant vanuit de Tabblad Authenticatiemethode, en die code gebruik ik om nadien op te slaan wat dus niet mogelijk blijkt te zijn.

De herhaaldelijk waarschuwing is

Waarschuwing
Authenticatie in twee stappen moet ingeschakeld zijn in uw profiel om het veld voor de geheime code te kunnen gebruiken


Maar ja, je moet dan wel alles kunnen opslaan om het werkende te krijgen.
meer dan een maand geleden
·
#18712
Is de gebruiker wel een superuser?
meer dan een maand geleden
·
#18713
yep, ook dat zoals op de foto
meer dan een maand geleden
·
#19168
Ik heb hetzelfde probleem. Is er al een oplossing voor gevonden?
meer dan een maand geleden
·
#19175
bij ons, is dat probleem nog niet opgelost
meer dan een maand geleden
·
#19176
Ik weet alleen dat er in Joomla 3.9.4 een bug zat met QR codes, die zal met de volgende release gefixt worden.
https://github.com/joomla/joomla-cms/issues/24252

Maar ik zag dat bij Joop het al in 3.9.1 speelde en ik weet niet of die bug toen al aanwezig was. (en hopelijk heb je je configuration.php alweer op 444 staan)

Joostock mede-organisator, JUG-organisator, moderator
Team Leader van Official Joomla Social Media Team
Eigen site: https://www.hierbenikthuis.nl

meer dan een maand geleden
·
#19179
De bug in Joomla 3.9.4 met de QR codes zou het probleem verklaren. Even wachten op de volgende release dus.
(Uiteraard staat mijn configuration.php op 444)
meer dan een maand geleden
·
#19207
Joomla 3.9.5 is uit, misschien dat het daarmee is opgelost? Een van de bug fixes is "Google Authenticator plugin (2FA): QR-code generator geïmplementeerd"
Anders misschien de QR-extensie verwijderen en opnieuw installeren?
  • Pagina :
  • 1
  • 2
Er zijn nog geen reacties op dit bericht.
Wees een van de eersten om op dit bericht te reageren!
Sorry de discussie is momenteel gesloten. U kunt nu geen reactie plaatsen.