1. JoopMantel
  2. de Cock De stem
  3. Overige vragen
  4. zaterdag 12 januari 2019
Joomla! 3.9.1

Ik ben er zojuist achtergekomen, dat de Google Authenticator instellingen niet werken.

Plugin is ingeschakeld alleen voor de beheerders gedeelte.

Bij gebruikers > beheren > gebruikers kies ik de de hoofd account.

  • Tabblad Authenticatiemethode in twee stapen
  • Keuze "Authenticatiemethode Google Authenticator "
  • Ipad keuze QR code scannen in Google Authenticator, voer ik in bij Beveiligingscode.
  • Na het opslaan, worden de ingevoerde code niet opgeslagen.

Ook wordt de nieuwe gegevens niet opgeslagen in de configuration.php die ik een chmod had gegeven 777.
Patrick Smits
Gebruikersgroep regio Utrecht
Geaccepteerde antwoord Pending Moderation
Voor zover ik weet klopt dit. De code wordt telkens opnieuw aangeboden en de kracht is dat er geen codes worden opgeslagen, waardoor hacking niet meer mogelijk is.
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 1
Geaccepteerde antwoord Pending Moderation
Ik begrijp dat de code opnieuw wordt aangeboden.

Echter wordt in de adminpanel niets opgeslagen, en alles blijft het zelfde nadien dat er geen Authenticator is ingeschakeld.

Authenticator kan men dus niet inschakelen.
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 2
Patrick Smits
Gebruikersgroep regio Utrecht
Geaccepteerde antwoord Pending Moderation
In het admin panel wordt ook niets opgeslagen, weet niet wat je daarmee bedoeld. Heb je voorbeelden, screenshots ...

Heb je onderstaande gedaan?
Als u Google Authenticator wilt gebruiken, schakel dan authenticatie in twee stappen in voor uw Google-account. Ga naar http://www.google.com/2step om aan de slag te gaan.
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 3
Patrick Smits
Gebruikersgroep regio Utrecht
Geaccepteerde antwoord Pending Moderation
Heb je al deze stappen doorlopen:

Hier
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 4
Geaccepteerde antwoord Pending Moderation
Zal het wellicht wel verkeerd beschrijven.

je hebt een drop down menu, de tweede keuze inschakelen van de authenticatie mogelijkheid.
Ik kan met de Ipad de QR code verkrijgen, die ik invul in het laatste veld die op die pagina staat.
Zodra ik alles op sla, is er niets ingesteld, en de keuzemenu staat weer op maak uw keuze om de authenticatie in te schakelen.
Ook gebeurd dat met de sleutel code die in de zelfde tabblad wordt vermeld dat er niets staat ingesteld.

Ik heb eerder nog nooit problemen gehad met de instellingen van een 2 weg authenticatie van google, nu dus wel en ik wil weten waarom dat nu ineens wel het geval is.
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 5
Patrick Smits
Gebruikersgroep regio Utrecht
Geaccepteerde antwoord Pending Moderation
Is de plug-in wel ingeschakeld? Staat namelijk standaard uit.
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 6
Geaccepteerde antwoord Pending Moderation
Zodra de plugin niet aan staat, kan men ook niet bij Tabblad Authenticatiemethode de keuzemenu kunnen gebruiken en of dat de tabblad dan zichtbaar wordt
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 7
Patrick Smits
Gebruikersgroep regio Utrecht
Geaccepteerde antwoord Pending Moderation
Dus je krijgt dit niet te zien na opslaan? Zie afbeelding.
Bijlagen
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 8
Geaccepteerde antwoord Pending Moderation
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 9
Patrick Smits
Gebruikersgroep regio Utrecht
Geaccepteerde antwoord Pending Moderation
Heb je verder in de backend problemen met opslaan?
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 10
Geaccepteerde antwoord Pending Moderation
Nee, verder heb ik geen problemen met het opslaan van gegevens zoals bij "algemene instellingen" en of met artikelen.

Alleen dus met Google Authenticator instellingen
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 11
Patrick Smits
Gebruikersgroep regio Utrecht
Geaccepteerde antwoord Pending Moderation
Geen idee wat er dan verkeerd gaat.
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 12
Geaccepteerde antwoord Pending Moderation
Juist ik dus ook niet, gezien dat het altijd heeft gewerkt.

Ik gebruik de juiste app van google, de juiste code die je scant vanuit de Tabblad Authenticatiemethode, en die code gebruik ik om nadien op te slaan wat dus niet mogelijk blijkt te zijn.

De herhaaldelijk waarschuwing is

Waarschuwing
Authenticatie in twee stappen moet ingeschakeld zijn in uw profiel om het veld voor de geheime code te kunnen gebruiken


Maar ja, je moet dan wel alles kunnen opslaan om het werkende te krijgen.
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 13
Patrick Smits
Gebruikersgroep regio Utrecht
Geaccepteerde antwoord Pending Moderation
Is de gebruiker wel een superuser?
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 14
Geaccepteerde antwoord Pending Moderation
yep, ook dat zoals op de foto
Bijlagen
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 15
Geaccepteerde antwoord Pending Moderation
Ik heb hetzelfde probleem. Is er al een oplossing voor gevonden?
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 16
Geaccepteerde antwoord Pending Moderation
bij ons, is dat probleem nog niet opgelost
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 17
Hans
Moderator
Geaccepteerde antwoord Pending Moderation
Ik weet alleen dat er in Joomla 3.9.4 een bug zat met QR codes, die zal met de volgende release gefixt worden.
https://github.com/joomla/joomla-cms/issues/24252

Maar ik zag dat bij Joop het al in 3.9.1 speelde en ik weet niet of die bug toen al aanwezig was. (en hopelijk heb je je configuration.php alweer op 444 staan)
JDoc-vertaler, JPatch tester, JUG-organisator, moderator
Eigen site: https://www.hierbenikthuis.nl en van mijn loopgroep: https://www.loopgroep-arnhemia.nl
Assistant Team Leader van het Joomla Social Media Team
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 18
Geaccepteerde antwoord Pending Moderation
De bug in Joomla 3.9.4 met de QR codes zou het probleem verklaren. Even wachten op de volgende release dus.
(Uiteraard staat mijn configuration.php op 444)
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 19
Geaccepteerde antwoord Pending Moderation
Joomla 3.9.5 is uit, misschien dat het daarmee is opgelost? Een van de bug fixes is "Google Authenticator plugin (2FA): QR-code generator geïmplementeerd"
Anders misschien de QR-extensie verwijderen en opnieuw installeren?
Webdeveloper bij Yolknet - yolknet.nl
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 20
  • Pagina :
  • 1
  • 2


Er zijn nog geen reacties op dit bericht.
Wees een van de eersten om op dit bericht te reageren!