1. André Kok
  2. Overige vragen
  3. woensdag 27 februari 2019
Voor een inschrijfformulier gebruik ik Visforms. na invullen door de gebruiker dient dit naar een bestuurslid gemaild te worden. Tot enkele weken (?) geleden heeft dit gewerkt, maar nu treedt de melding "Attentie: Kan mailfunctie niet opstarten" op.
Bij Algemene instellingen - E-mailinstellingen staat bij Mailer: PHP-mail. Dit staat al vanaf het begin ingesteld en is nooit anders geweest.
Bij mijn andere website maak ik op dezelfde manier gebruik van Visforms, maar daar werkt het mailen wel. Bij die site is bij Algemene instellingen - E-mailinstellingen staat bij Mailer: SMTP ingesteld.
Wie kan mij vertellen wat de oorzaak is?
Geaccepteerde antwoord Pending Moderation
Ik heb vandaag tamelijk uitgebreid getest. Resultaten waren reproduceerbaar.
Eerst met PHP mailer: welke E-mailadressen ik waar ook invul, het blijkt dat de mail naar de bestemming (To en evt. CC) steeds niet lukt, terwijl de bevestigingsmail naar de invuller steeds wel werkt.
Toen SMTP ingesteld: met succes! Beide mails worden verstuurd.
Toen weer PHP mailer ingesteld: dezelfde problemen als eerst.
Ik heb nu weer SMTP ingesteld: het werkt weer goed.
Het lijkt er sterk op dat SMTP wel betrouwbaar werkt en PHP mailer niet.
Begrijpen doe ik het niet, maar mede gezien de ervaring met mijn andere website houd ik het mooi op SMTP!

Groet, André
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 1
Geaccepteerde antwoord Pending Moderation
Eerder had ik het kpnmail.nl-adres als doeladres. Dat leek dus de foutmelding te geven.
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 2
Geaccepteerde antwoord Pending Moderation
Welke mail adres had je normaal dan als doeladres?

Groeten Ron
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 3
Geaccepteerde antwoord Pending Moderation
Die 'iemand' is de tussenpersoon die onze website sponsort. :)

Ik heb de mailadressen omgewisseld: nu doeladres: een gmail.com-adres, en recipient (bevestiging naar invuller): een kpnmail.nl-adres. En nu werkt het feilloos! (En morgen misschien weer niet. :()
Het komt allemaal niet betrouwbaar bij mij over. Zou SMTP betrouwbaarder werken dan PHP mailer?

Ik heb eerder met de andere website gehad dat mails naar een gmail-box in de Spam-map terecht kwam en bij een hotmail-box geheel niet aankwam. Oplossing was instellen van SPF, DKIM en DMARC-zaken.

André
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 4
Geaccepteerde antwoord Pending Moderation
Die iemand is niet een van het forum denk ik? ;)

Heb je ook al een ander mail adres geprobeerd/getest?

Soms komt het ook voor wanneer je de mail naar bijvoorbeeld @gmail adres verstuurd dan komt hij niet aan om het geen mail adres is van het domein.

Succes ermee.

Groeten Ron :)
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 5
Geaccepteerde antwoord Pending Moderation
Het punt is dat het af en toe wel werkt. Het versturen van het "Afmeldformulier" naar de bedoelde ontvanger werkt niet, maar naar de recipient (als bevestiging naar de invuller) werkte zojuist wèl.
Ik wil inderdaad SMTP proberen, maar iemand moet nog een wachtwoord voor het verzendadres leveren. Even geduld nog.
Bedankt zover.

André
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 6
Geaccepteerde antwoord Pending Moderation
En werkt het versturen met smtp wel? zo als bij je andere site.

Groeten Ron :)
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 7
Geaccepteerde antwoord Pending Moderation
Ik heb de gebruikelijke updates van Joomla! gedaan. Niet van PHP.

André
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 8
Geaccepteerde antwoord Pending Moderation
Hallo,

je zegt dat het wel heeft gewerkt.

Dus de vraag is heb je in tussen tijd een update van joomla gedaan? Of PHP misschiein?

Groeten Ron :)
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 9
Geaccepteerde antwoord Pending Moderation
Ik kom dit tegen op de site van Vi-solutions (Visforms):
Mail-Funktion konnte nicht gestartet werden!
Daar wordt gesteld dat de melding wordt veroorzaakt als zowel bij de formulierinstellingen als bij de Algemene Instellingen - Server - E-mailinstellingen geen afzender is ingesteld, maar dat is bij mij wel voor elkaar. Verder wordt gesuggereerd dat het niet aan Visforms ligt, maar aan de Joomla!-installatie, met name rond PHP Mailer.
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 10
Geaccepteerde antwoord Pending Moderation
Ik ontdek zojuist dat een Joomla!-contactformulier wel per mail verstuurd wordt. Het lijkt dus niet aan de Algemene instellingen rond E-mail te liggen, maar wellicht aan Visforms.
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 11
  • Pagina :
  • 1


Er zijn nog geen reacties op dit bericht.
U mag echter niet reageren op dit bericht.
Sorry de discussie is momenteel gesloten. U kunt nu geen reactie plaatsen.