dinsdag 02 februari 2021
  4 Replies
  186 Visits
Hallo,

Even een vraag waar ik niet uitkom.
als ik een menu-item maak, en deze aan een artikel link, dan werkt dat (uiteraard).
ik krijg dan domein.nl/partners
Als ik dan vervolgens daar weer een menu-item onderhang, naar een externe URL, dan werkt dat ook.
Ik krijg dan domein.nl/partners/bedrijf en als ik hier op klik ga ik naar die URL.

Als ik nu het eerste menu-item op "Verborgen" zet, dan werkt wel de domein.nl/partners nog, maar de domein.nl/partners/bedrijf werkt niet. Ik krijg een 404 pagina.

Is dit überhaupt wel mogelijk? Of kan dit op een andere manier gerealiseerd worden?

Groet, Peter
4 weken geleden
·
#22431
Het lijkt me dat dit hetzelfde zou moeten werken als een interne link, immers de structuur en opbouw is hetzelfde gebleven enkel je menu item is verborgen voor publiek maar bestaat nog.
4 weken geleden
·
#22435
Ik heb het even getest met een interne link, en dan werkt het ook niet.
Misschien als het ik hoofdmenu verplaats naar een nieuw menu die ik niet publiceer. Ik zal dat even testen.

Gr.Peter
4 weken geleden
·
#22436
Hallo,

mmmm vreemd als ik een externe URL maak bijvoorbeeld https://www.google.nl dan is het menu item URL ook https://www.google.nl

Heb als test menu item part gemaakt met een artikel eraan gekoppeld, en daar weer aan gekoppeld (submenu) menu item met externe URL Google.

En de URL van het submenu blijft dus https://www.google.nl, dus de URL domein.nl/part/google.nl kan ik niet maken/genereren.

Dus ik vermoed dat je een SEF extensie gebruikt om mooiere URL's te krijgen klopt dat? En dat daaruit het probleem ontstaat.

Groeten Ron :)
4 weken geleden
·
#22437
Een menu-item van het type externe url heeft geen alias, zie ook je eigen screenshot. Dus je kunt dat niet als url gebruiken.
  • Pagina :
  • 1
Er zijn nog geen reacties op dit bericht.
Wees een van de eersten om op dit bericht te reageren!