1. Rob Laroy
  2. Overige vragen
  3. maandag 08 april 2019
Probleem met linken en openen van de website op bv. een androidtelefoon met Chromebrowser

Ik beheer de website http://www.btve68.nl
Nu stuur ik soms de leden van de vereniging een mailtje met een directe link naar de site, als service. Sommige leden melden dan een probleem, dat ik zelf overigens ook op mijn androidtelefoon kreeg:

kort klikken op de link om de site te openen levert direct de reactie:

404 Not found, the requested URL
/7a0cdf.php
was not found on this server

Ik wil voorkomen dat iemand die foutmelding krijgt. Hoe los ik dat op?

Toelichtende informatie die het probleem zou kunnen adresseren:

Lang klikken op de link in de email geeft een scherm met de mogelijkheid " Openen in browser" , en dan komt de website netjes in beeld.
Ook het kopieren en plakken van de link in de brower gaat goed.

Is redirect een oplossing?
Ik heb geprobeerd om het probleem op te vangen met de ingebouwde component "Verwijzingen" in Joomla. Daar wordt de tekst /7a0cdf.php echter niet geaccepteerd als Verlopen URL met als foutmelding: "De bron-URL moet uniek zijn."

Ik kan het probleem op mijn telefoon oplossen door de volgende handelingen uit te voeren:
Lang klikken op de link "openen in browser"
Dan kiezen voor een andere browser, bv. die van Samsung, en kiezen voor "altijd"
Nu weer terug naar de mail en kort klikken. Nu opent de link zonder fouten in de Samsung browser!
Nu weer terug naar de mail en lang klikken en dan weer kiezen voor de Chromebrowser, en kiezen voor "altijd". De foutmelding is weg en komt niet meer terug.

Maar terug naar het probleem:
Ik kan deze handelingen natuurlijk niet verwachten van iemand die mijn mail krijgt, en hoe kan ik nu de foutmelding direct afvangen en laten verwijzen naar de goede URL?
Alvast dank voor de suggesties voor een oplossing!
Rob
Hans
Moderator
Geaccepteerde antwoord Pending Moderation
Waar komt dat "/7a0cdf.php" van? Want dat is niet een normaal Joomla item. Het het artikel zo?

Of is dat de link die in je mail hebt gezet?
Schrijf je zelf de mail of gebruik je hiervoor een extensie?
JDoc-vertaler, JPatch tester, JUG-organisator, moderator
Eigen site: https://www.hierbenikthuis.nl en van mijn loopgroep: https://www.loopgroep-arnhemia.nl
Assistant Team Leader van het Joomla Social Media Team
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 1
Geaccepteerde antwoord Pending Moderation
Dag Hans, dank voor je snelle reactie.
Bij de poging om de website te openen via een link in de mail krijgen sommigen dus de melding:

404 Not found, the requested URL /7a0cdf.php was not found on this server

Google genereert dus deze reactie.
De website werkt verder prima (denk ik..., zou je ook kunnen zien als je hem bezoekt).
De mail kan ik maken via een gewone OUTLOOK 2013, maar ook als de mail is gegenereerd met ons externe ledenadministratieprogramma ontstaat dezelfde 404- NOT found error.
Ik heb geen idee in welke richting ik de fout moet zoeken.
Rara...?
Rob
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 2
Geaccepteerde antwoord Pending Moderation
Hallo Leden,

in het verleden is de site niet gehakt geweest? Want in het verleden heb ik ook gehackte sites gezien die eindigen met z'n rare url.php

Probleem doet zich dus niet voor op desktop?

Vriendelijke groeten,

Ron :)
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 3
Hans
Moderator
Geaccepteerde antwoord Pending Moderation
Ik wilde mijn vermoeden nog niet uitten maar ook is mijn gedachte bij vreemde URL's dat er een kans is dat de site gehackt is. Dat of de de PC/browser van de bezoeker is met malware besmet.

Zou je een stukje voorbeeld van de code in de mail kunnen plaatsen? Dus waarin de link zit. Mocht dit lastig zijn, zou je anders zo'n mail kunnen sturen naar gmail.com ?
JDoc-vertaler, JPatch tester, JUG-organisator, moderator
Eigen site: https://www.hierbenikthuis.nl en van mijn loopgroep: https://www.loopgroep-arnhemia.nl
Assistant Team Leader van het Joomla Social Media Team
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 4
Geaccepteerde antwoord Pending Moderation
Ron en Hans, Dat klopt!
Er is een zo'n twee jaar geleden een hack geweest, die door een ingehuurde prof is opgelost.
Op mijn desktop heb ik het probleem niet.
Hans, Ik snap even niet welke code je bedoelt. Ik kan je wel een mailtje sturen met de link naar de site https://www.btve68.nl en dan kun je zelf zien bij jou de 404 Not found fout wordt gegenereerd of dat je gewoon naar de site wordt doorgelinkt. WIl je dat?
Groet,
Rob
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 5
Geaccepteerde antwoord Pending Moderation
Ron en Hans,
Ik krijg zojuist nog een reactie van iemand die in Chrome dat hij altijd gebruikt, de foutmelding kreeg, maar met Firefox, na mijn verzoek gebruikt, niet. Wellicht zit het probleem nog in de history van Chrome?
Rob
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 6
Geaccepteerde antwoord Pending Moderation
Ik stuur je nu een pm met mijn mail adres dan wil ik ook kijken of ik de 404 krijg.

Wacht je reactie af.

Groeten Ron :)
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 7
Hans
Moderator
Geaccepteerde antwoord Pending Moderation
Zou degene dit nu in FF geen problemen heeft zijn PC willen scannen op malware?
JDoc-vertaler, JPatch tester, JUG-organisator, moderator
Eigen site: https://www.hierbenikthuis.nl en van mijn loopgroep: https://www.loopgroep-arnhemia.nl
Assistant Team Leader van het Joomla Social Media Team
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 8
Hans
Moderator
Geaccepteerde antwoord Pending Moderation
Ik zie dat het enige wat je doet is de link naar de website in een mailtje plaatsen. Dit kan nooit misgaan via de mail op deze manier. Mijn vermoeden is dat de betreffende gebruiker last heeft van malware op zijn PC waardoor Chrome besmet is geraakt.
JDoc-vertaler, JPatch tester, JUG-organisator, moderator
Eigen site: https://www.hierbenikthuis.nl en van mijn loopgroep: https://www.loopgroep-arnhemia.nl
Assistant Team Leader van het Joomla Social Media Team
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 9
Geaccepteerde antwoord Pending Moderation
Ik heb de vraag doorgespeeld via de mail. Dat antwoord kan natuurlijk wel even op zich laten wachten, want ik weet niet wanneer dat scannen gebeurt.
Rond 21.45 uur stop ik ook (afspraak met mijn vrouw....) Dan morgen weer verder OK?
Groet,
Rob
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 10
Geaccepteerde antwoord Pending Moderation
Hier ook geen last met Firefox en Chrome op Android toestel.

Groeten Ron :)
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 11
Geaccepteerde antwoord Pending Moderation
Hallo,
Het valt me op dat als ik via google zoekt naar
btve68.nl

ik dan in elke browser dus FF IE11 en Google Chrome de website boven in ziet staan
en als ik daar dan op link klikt krijg ik de error melding ook. of pagina niet gevonden.
Zou het kunnen zijn dat mogelijk iets in htaccess aangepast is of zoiets
Bijlagen
lvda
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 12
Geaccepteerde antwoord Pending Moderation
Dag Leen,
Dank voor dit nieuwe gezichtspunt. Ik kan kijken of mij iets opvalt, maar ik heb geen ervaring op dat onderdeel. Even studeren, en ik kom er op terug.
Rob
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 13
Geaccepteerde antwoord Pending Moderation
Heren,
Ik vind in mijn zowel in mijn hoofdmap als mijn submap /administrator een htaccess bestand (beide verschillend).
In beide bestanden tref ik echter aan het volgende:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{HTTP_USER_AGENT} google [OR]
RewriteCond %{HTTP_REFERER} google
RewriteCond %{REQUEST_URI} !(\.js|\.css|\.png|\.jpg|\.jpeg|\.gif|\.svg|\.ttf|\.woff|\.eot)
RewriteRule ^.*$ 7a0cdf.php [L]
</IfModule>

Daar lijkt dus de oorzaak van de foutmelding. (zie de op één na laatste regel van de
Wat is nu de vervolgstap? De htaccesbestanden allemaal gewoon verwijderen? Of de laatste regel in het htaccess bestand waarin de RewriteRule staat aanpassen? NIeuwe htaccessbestanden maken?
Ik zie dat in de htaccess in de hoofdmap nog heel veel onduidelijke rommel staat, waarschijnlijk overgebleven van een vorige hack.
Ik heb gelezen dat de htaccess in de hoofdmap wordt overruled door de htaccess in de submap, dus zou de htaccess in de hoofdmap kunnen worden vervangen door de htaccess in de submap, OK?
Zeer graag advies, in dit onderdeel ligt waarschijnlijk de oorzaak van mij probleem.
Rob
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 14
Geaccepteerde antwoord Pending Moderation
Hallo Rob,
Als je ook in administrator map een htaccess heb staan gebruik je zeker een beveiliging's extensie ?
(ik kan namelijk niet de administrator inlog pagina benaderen dan kom ik gelijk weer bij front uit)
Is deze dan nog wel up to date ?
En kan je eventueel ook zien wanneer die htaccess is gemaakt.
En vaak is als er een upgrade van joomla is geweest ook een nieuwe htacess.txt er bij geleverd.
dus in hoofdmap zou je eens de oude kunnen hernoemen naar htaccess.oud of zo
en dan de nieuwste htaccess.txt weer hernomen naar .htaccess
Maar misschien weet iemand anders nog een betere oplossing
Maar voor je iets wijzig maak wel een goed back-up eerst
lvda
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 15
Geaccepteerde antwoord Pending Moderation
Dag Leen,
De htaccess bestanden waren van 2016.
Ik heb de htaccess bestanden via FTP gezekerd, en daarna verwijderd uit de site.
De aanwezige htaccess.txt heb ik niet aangepast.
Alles lijkt nu perfect te werkten!!! Ook als je via de zoekmachine Google de site opzoekt werken alle links prima en komen uit op mij beveiligde site.
Als administrator kan ik ook netjes inloggen en aan de site werken.
Dit maar zo houden of moet ik via htaccess toch nog iets toevoegen?
Rob
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 16
Geaccepteerde antwoord Pending Moderation
Hallo Rob,

ik neem aan dat je toch nog wel een .htaccess ergens staat
(of ik begrijp dit niet geheel goed
Ik heb de htaccess bestanden via FTP gezekerd, en daarna verwijderd uit de site.
)
Maar ik ben zelf niet zo goed met regels aanpassen inde .htaccess vandaar dat ik vaak zelf de meest recente htaccess.txt dan
vernoemt naar .htaccees
Maar omdat ik er vanuit gaat dat jou website gebruik maakt van een beveiliging extensie neem ik aan dat die
ook dan de htaccess bijwerkt .
Maar nogmaals dit is niet mijn sterkste punt dus ik hoop dat iemand met meer ervaring op dit gebied
iets betere tips kan geven wat het beste is om te doen.
lvda
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 17
Geaccepteerde antwoord Pending Moderation
Inderdaad, ik zie nergens meer een .htaccess bestand, alleen een htaccess.txt van maart 2019.
Moet er perse een .htaccess bestand zijn?
Na 15.00 uur ben ik weer thuis en kan ik alle submappen nog nazoeken.
Daarna laat ik weten wat ik heb gevonden.
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 18
Geaccepteerde antwoord Pending Moderation
daarom ben ik ook verbaast dat alles op de website nog zou werken zonder .htaccess
normaal gesproken dacht ik dat dan de gebruik url herschrijven niet goed meer ging
als die in administrator > Algemene instellingen > Gebruik URL herschrijven aanstaat.
en daar er eerst wel .htaccess stond met dat vreemde regeltje er naar die vreemde php.
Ik zelf denk dus dat geen kwaad kan om de recente htaccess.txt in hoofdmap toch
dan even te hernoemen naar .htaccess (als het onverhoopt dan niet goed gaat kan je hem weer terug vernoemen)
Bijlagen
lvda
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 19
Geaccepteerde antwoord Pending Moderation
Leen, Dank voor je suggestie.
Morgen ga ik dat uitproberen.
Wat mij betreft is mijn probleem hiermee op de juiste wijze aangepakt en kan ik verder werken aan een correct .htaccess bestand.
Dank voor de ondersteuning.
Rob
  1. meer dan een maand geleden
  2. Overige vragen
  3. # 20
  • Pagina :
  • 1


Er zijn nog geen reacties op dit bericht.
U mag echter niet reageren op dit bericht.
Sorry de discussie is momenteel gesloten. U kunt nu geen reactie plaatsen.