zaterdag 17 april 2021
  2 Replies
  202 Visits
Goedendag,

Ik heb een probleem en ik zie niet de oorzaak. Ik gebruik een custom font Aristotelica Pro. Bij de instellingen van de template (LT Donut) heb ik bij de Typography voor alle koppen Google Fonts uitgeschakeld. Ik heb het volgende toegevoegd aan de stylesheet default.css:


font-family: 'aristotelica_pro_displayXLt';
src: url('zetafonts_-_aristotelica_pro_display_extralight-webfont.woff2') format('woff2'),
url('zetafonts_-_aristotelica_pro_display_extralight-webfont.woff') format('woff');
font-weight: normal;
font-style: normal;


Ik heb de volgende font-files toegevoegd:


  • Zetafonts - Aristotelica Pro Display Extralight.otf
  • zetafonts_-_aristotelica_pro_display_extralight-webfont.woff2
  • zetafonts_-_aristotelica_pro_display_extralight-webfont.woff


Om uit te sluiten dat hij de verkeerde directory probeert uit te lezen heb ik ze in de volgende directories geplaatst:


  • /public_html/templates/lt_donut/fonts
  • /public_html/templates/lt_donut/webfonts
  • /public_html/templates/lt_donut/css


Desondanks blijf ik het probleem houden dat hij niet Aristotelica Pro laat zien, maar een standaard font (ik gok Times New Roman). Vraag ik echter met Chrome Inspector de stylesheet settings op van een willekeurige koptekst, geeft deze wel aan dat Aristotelica Pro zou moeten worden weergegeven.

Heeft iemand enige idee wat ik hier nu over het hoofd zie?

PHP 7.4.14
Joomla 3.9.26
Helix3 2.5.8
SP Page Builder 3.1

Alvast bedankt voor de moeite die genomen is om dit te lezen en nog meer voor elke hulpvaardige reactie die wordt gegeven.

Domein: http://www.geopendedeur.online
3 weken geleden
·
#22776
Geaccepteerde antwoord
Je font-face definitie ontbreekt.
Dit zou moeten werken:

@font-face {
font-family: 'aristotelica_pro_displayXLt';
src: url('zetafonts_-_aristotelica_pro_display_extralight-webfont.woff2') format('woff2'),
url('zetafonts_-_aristotelica_pro_display_extralight-webfont.woff') format('woff');
}
h1, h2, h3, h4, h5 {
color: #771469;
font-family: 'aristotelica_pro_displayXLt';
font-weight: normal;
font-style: normal;
}
3 weken geleden
·
#22776
Geaccepteerde antwoord
Je font-face definitie ontbreekt.
Dit zou moeten werken:

@font-face {
font-family: 'aristotelica_pro_displayXLt';
src: url('zetafonts_-_aristotelica_pro_display_extralight-webfont.woff2') format('woff2'),
url('zetafonts_-_aristotelica_pro_display_extralight-webfont.woff') format('woff');
}
h1, h2, h3, h4, h5 {
color: #771469;
font-family: 'aristotelica_pro_displayXLt';
font-weight: normal;
font-style: normal;
}
Herman Bos selected the reply #22776 as the answer for this post — 3 weken geleden
3 weken geleden
·
#22777
Super bedankt.
  • Pagina :
  • 1
Er zijn nog geen reacties op dit bericht.
Wees een van de eersten om op dit bericht te reageren!