1. André Kok
  2. Templates
  3. zondag 01 april 2018
Er meldt zich een nieuwe update voor Helix3. Als ik die wil doorvoeren krijg ik een waarschuwing "Updatepad bestaat niet" en een bericht "Fout bij het updaten van COM_INSTALLER_TYPE_TYPE_". Zie ook de bijlage. Wat is er aan de hand?
(Dit gebeurt op de online site https://zwaluwengramsbergen.nl/joomla/. Lokaal op mijn PC waar precies dezelfde site staat krijg ik een andere foutmelding.)

André
Bijlagen
Rondeb Geaccepteerde antwoord Pending Moderation
Denk dat je de update even handmatig moet downloaden via joomshaper :)

Groeten Ron
  1. 3 weken geleden
  2. Templates
  3. # 1
André Kok Geaccepteerde antwoord Pending Moderation
Er dient zich een update van Sigplus aan. Als ik die wil uitvoeren krijg ik precies dezelfde foutmelding als eerder met Helix3. Er lijkt iets structureels niet goed te zijn. Iemand een idee?

André
  1. 2 weken geleden
  2. Templates
  3. # 2
André Kok Geaccepteerde antwoord Pending Moderation
Ook het installeren van een nieuwe extensie rechtstreeks vanuit Extensiebeheer in Joomla werkt niet. Fout:
"Kan geen installatiepakket vinden"
Help!

André
  1. 2 weken geleden
  2. Templates
  3. # 3
André Kok Geaccepteerde antwoord Pending Moderation
Ik kan helemaal niks installeren, zowel geen nieuwe extensies als updates. Ik heb zojuist gepoogd handmatig Showplus te installeren via Installeren vanuit map nadat ik het ZIP-bestand uitgepakt had en met Filezilla geupload had naar de map tmp. Dan komt de foutmelding dat de map modules/mod_showplus niet gecreëerd kan worden. Die heb ik via Filezilla aangemaakt. Weer geprobeerd, maar nu de melding "JFolder::create: Pad bevindt zich niet in open_basedir pad. Cannot create destination folder".
Er is iets niet goed, maar wat???

André
Bijlagen
  1. 2 weken geleden
  2. Templates
  3. # 4
Rondeb Geaccepteerde antwoord Pending Moderation
Hallo,

het pad van je log en tmp map staan (nog) wel goed bij algemene instellingen?

Om je pad te achterhalen kijk hier eens.

En kijk ook in je backend van je site bij systeem --> systeeminformatie --> tab Maprechten
Zie of alles op groen staat behalve configuration.php

Succes ermee.

Groeten Ron :)
Bijlagen
  1. 2 weken geleden
  2. Templates
  3. # 5
André Kok Geaccepteerde antwoord Pending Moderation
Ron,
Ik heb het path gecontroleerd. De paden in de Systeeminformatie zijn alle in orde behalve evt. cookie_path. Dus mappen log_path en tmp_path zijn correct ingesteld.
Bij Maprechten staat alles op groen (schrijfbaar), dus ook configuration.php.
Bedankt zover.

André
  1. een week geleden
  2. Templates
  3. # 6
Rondeb Geaccepteerde antwoord Pending Moderation
Heb je de originele .htaccess file of een aangepaste?

Probeer je cache op te schonen van je browser en site, en eventueel een andere webbrowser proberen.

Groeten Ron :)
  1. een week geleden
  2. Templates
  3. # 7
André Kok Geaccepteerde antwoord Pending Moderation
Hmm, ik heb geen .htaccess bestand. Wel een htaccess.txt origineel van Joomla, in de submap waar de joomla-site in staat. Zal ik dit besatnd hernoemen naar .htaccess?
Bij de instellingen is cache uitgeschakeld. Bij Systeem heb ik Opschonen verlopen cache en Wissen cache uitgevoerd. Het helpt allemaal niet.
Andere webbrowser (IE): hé, ik kan nu helemaal niet meer inloggen! Ook niet in Firefox.
Morgen is er weer een dag met nieuwe kansen.

André
  1. een week geleden
  2. Templates
  3. # 8
Rondeb Geaccepteerde antwoord Pending Moderation
Hoi,

je mag als je wilt inlog van de website toesturen dan wil ik wel een kijkje nemen.

Natuurlijk deel de oplossing hier ;)

Groeten ron :)
  1. een week geleden
  2. Templates
  3. # 9
André Kok Geaccepteerde antwoord Pending Moderation
Dat is een goed idee, maar ik kan niet meer in Joomla backend inloggen! Ik voer username en password in en zodra ik Enter geef of op Login klik schieten de velden username en password leeg en gebeurt er niets.
Heb ik gisteren iets te veel op Cache opschonen of wissen geklikt?
Kan ik via PhpMyAdmin iets herstellen?

André
  1. een week geleden
  2. Templates
  3. # 10
Rondeb Geaccepteerde antwoord Pending Moderation
Avond,

te veel cache opschonen moet dit probleem niet veroorzaken meerdere keren je cache is alleen maar goed!

Groeten Ron
  1. een week geleden
  2. Templates
  3. # 11
Rondeb Geaccepteerde antwoord Pending Moderation
Middag,

heb in/op de test site gekeken van André en ik krijg het update van geen enkele extensie aan de gang.

De site is ondergebracht bij Transip zag ik wat later en toen ging er een belletje rinkelen bij mij dat die partij niet echt Joomla vriendelijk is. Ook via google kom ik veel negatieve berichten tegen over joomla hosting bij Transip.

Uit nood heb ik een back-up van de site op mijn hosting (vimexx) gezet en daar kon ik alles vlekkeloos update.

Dus ik heb André geadviseerd om contact te zoeken met Transip. En dat zei toch serieus naar dit probleem moeten gaan kijken en natuurlijk oplossen.

En anders is de enigste oplossing om over te gaan op een andere hosting.

Groeten Ron :)
  1. een week geleden
  2. Templates
  3. # 12
André Kok Geaccepteerde antwoord Pending Moderation
We hebben TransIP om een oplossing gevraagd en men is met de volgende workaround gekomen, die hier bij de community ook al bekend bleek te zijn:
In het bestand libraries/joomla/filesystem/folder.php de volgende regel (regel ~252):
if (strpos($path, $test) === 0)

vervangen door:
if (strpos($path, $test) === 0 || strpos($path, realpath($test)) === 0)

Dat leek in eerste instantie niet te werken. Vervolgens de map voor tijdelijke bestanden gewijzigd van /www/joomla/tmp in /tmp (de site staat voorlopig in de submap /www/joomla) en toen werkte het updaten wel!

TransIP zegt e.e.a. aangekaart te hebben bij de Joomla-gemeenschap.

Die workaround (het aanpassen van folder.php) moet bij elke update van Joomla gebeuren of gecontroleerd worden.
Ik neem dit voorlopig voor lief. Ik kan niet van hostingbedrijf wisselen en ik stap ook niet over op WordPress.
Ik bedank met name Ron voor de hulp.

André
  1. een week geleden
  2. Templates
  3. # 13
Hans van der Meer Geaccepteerde antwoord Pending Moderation
Moderator
Als ik op Github op het trefwoord "realpath" zoek zie ik deze issue, die is inmiddels in Joomla 3.8.6 doorgevoerd.
https://github.com/joomla/joomla-cms/pull/19608

Typisch is dat ik zag dat je website wel al op 3.86 zit.
JDoc-vertaler, JPatch tester, JUG-organisator, moderator
Eigen site: https://www.hierbenikthuis.nl en van mijn loopgroep: https://www.loopgroep-arnhemia.nl
Assistant Team Leader van het Joomla Social Media Team
  1. een week geleden
  2. Templates
  3. # 14
André Kok Geaccepteerde antwoord Pending Moderation
Die discussie gaat over tmp_path, begrijp ik. Het zou kunnen dat ik die zelf in het begin op /www/joomla/tmp heb gezet omdat dat mij handig leek i.v.m. verplaatsen van de hele site van submap naar hoofdmap zodra die gereed zou komen. Ik dacht nl. dat het om relatieve paden ging. Maar vraag me niet verder. :)

André
  1. een week geleden
  2. Templates
  3. # 15
  • Pagina :
  • 1


Er zijn nog geen reacties op dit bericht.
U mag echter niet reageren op dit bericht.
Sorry de discussie is momenteel gesloten. U kunt nu geen reactie plaatsen.