Afgelopen oktober kondigde Joomla! al aan dat Joomla! vanaf 22 juli 2009 zal stoppen met de ondersteuning voor de Joomla! 1.0 serie. Als vervolg op dit besluit is vandaag bekend gemaakt dat ook de Joomla! 1.0 extensies gefaseerd zullen verdwijnen uit de Joomla! Extensions Directory (JED). De planning ziet er als volgt uit:

  • 13 oktober 2008: Bekendmaking 'end of life' van Joomla! 1.0
  • 31 maart 2009: Er worden geen nieuwe Joomla! 1.0 extensies meer toegevoegd aan JED
  • 30 juni 2009: Joomla! 1.0 extensies zullen uit de JED verdwijnen
  • 22 juli 2009: Joomla! 1.0 'end of life'

Voor 30 juni is gekozen omdat deze dicht bij de 'end of life' datum ligt van Joomla! 1.0 en zodat de gebruikers en ontwikkelaars een half jaar de tijd hebben hun plannen bij te stellen.

Dit besluit komt voort uit een aantal redenen; allereerst zullen oudere extensies gebaseerd zijn op oudere code en daardoor een groter veiligheids risico vormen, tevens zijn er veel 'oude' extensies te vinden welke niet meer ondersteund en onderhouden worden. Daarnaast worden de ontwikkelaars nog meer gedwongen zich op Joomla! 1.5 te richten.

Uiteindelijk resulteert dit in een opgeschoond aanbod van extensies welke allen geschikt zijn voor Joomla! 1.5 waardoor je allicht weer eenvoudiger je extensies kunt vinden.

Lees de officiële aankondinging op Joomla.org: JED Will Phase Out Joomla 1.0 Extensions in June 2009

2 reacties

EasyDiscuss Avatar
David-Andrew
Hier ben ik echt HEEL blij mee! 8)
EasyDiscuss Avatar
Marco Richter
Ik vind dit ook erg goed. Zal voor enige mensne lastig worden maar goed het is wel een push om te migreren naar 1.5.x

Reageer

1000 Resterende tekens