1. MarVan
  2. de Cock
  3. Webhosting
  4. woensdag 11 september 2019
Ik heb een website overgenomen waarop nog joomla-versie 3.7.5 stond geïnstalleerd en php-versie 5.6.4.
Joomla heb ik voor de overname nog kunnen opdaten naar 3.9.11 maar de php niet.
In het begin geraakte ik nergens op, kreeg telkens foutmeldingen en nadat op mijn hosting de php-versie werd teruggedraait van 7.3 naar 5.6 werkte alles wel, maar ik kan in de backend maar 1 maal komen. Zodra de backend opnieuw wordt ingeladen, omdat ik bvb. verder klik op beschikbare updates van extensies, krijg ik foutmeldingen van /libraries/src/Session/Session.php.
De meldingen aangaande dit bestandje zijn:
Notice: unserialize(): Error at offset 620 of 623 bytes
Fatal error: Call to a member function get() on boolean
Fatal error: __clone method called on non-object


Weet iemand hoe ik dit moet aanpakken zodat ik gantry en dergelijke kan updaten? Ik zou immers toch naar de recentste php-versie kunnen gaan.
Geaccepteerde antwoord
Geaccepteerde antwoord Pending Moderation
Ha dan wordt het lastig denk ik .
maar je had het eerder over
(komt uit een plesk-omgeving)
kan je daar nog wel komen dan
misschien dat daar iets staat wat de administrator afschermt
geef anders eens op waar de site is gehost, ik lees hier iets over een toolit . in plesk ?
lvda
  1. meer dan een maand geleden
  2. Webhosting
  3. # Permalink
Geaccepteerde antwoord Pending Moderation
Hallo,
mijn hosting de php-versie werd terug gedraait van 7.3 naar 5.6

is er bij de hoster ook nog keuze voor andere eventueel php versie 7.2.22 of zoiets maar lager dan 7.3
lvda
  1. meer dan een maand geleden
  2. Webhosting
  3. # 1
Geaccepteerde antwoord Pending Moderation
Dag Leen

Dat gaat, maar dat biedt geen oplossing.
Ik heb de eerste maal de website met de oude Joomla-versie ingeladen omdat ik op ons eigen domein wou updaten, en dat was met PHP 7.1, maar ook dat liep fout.
  1. meer dan een maand geleden
  2. Webhosting
  3. # 2
Geaccepteerde antwoord Pending Moderation
maar heb je dat ook al eens geprobeerd met eventueel de foutrapportage aan op maximum
of je iets kan ontdekken voor dat je gaat upgraden of zo
Bijlagen
lvda
  1. meer dan een maand geleden
  2. Webhosting
  3. # 3
Geaccepteerde antwoord Pending Moderation
Ik heb, via de ftp, de foutreportage al op "development" gezet, maar ik krijg enkel foutmeldingen die, als ik ga googelen, gerelateerd zijn aan de php-versie. Maar mij lijkt het een vicieuze cirkel, ik kan niet in de backend blijven omdat de achterliggende code niet meer ondersteund wordt wegens verouderde php en ik kan de php-versie niet updaten omdat de website dan niet meer werkt.
  1. meer dan een maand geleden
  2. Webhosting
  3. # 4
Geaccepteerde antwoord Pending Moderation
Hallo Marvan,

kun je de foutmeldingen delen met ons?

Er is toch een extensie of template die niet overweg kan met PHP 7.x

Groeten Ron :)
  1. meer dan een maand geleden
  2. Webhosting
  3. # 5
Geaccepteerde antwoord Pending Moderation
Dag Ron
In bijlage vind je de foutmeldingen voor zowel backend als frontend. Ik heb zonet die session.php eens vergeleken met die van een andere website en die regels komen helemaal overeen. Alleen bij de andere website werkt alles en hier niet. foutmeldingen backend.png foutmeldingen frontend.png
Bijlagen
  1. meer dan een maand geleden
  2. Webhosting
  3. # 6
Geaccepteerde antwoord Pending Moderation
Ik heb ook al gezien dat er updates klaar staan van Gantry, RockNavMenu en de Weblink extension Package. Maar dat zie ik alleen als ik in de backend links onderaan klik op extensies. Als ik bovenaan klik op extensieupdates, krijg ik de genoemde foutmeldingen. Ik durf dus niet goed de extensieupdates aan te klikken en te updaten want ik vrees dat ik dan ook die foutmeldingen ga krijgen.
  1. meer dan een maand geleden
  2. Webhosting
  3. # 7
Geaccepteerde antwoord Pending Moderation
Hallo Marvan,
Als ik lokaal op pc een kale joomla 3.7.5 installeer met php 5.6.35 werkt alles oke ook administrator
als ik php versie verhoogt naar 7.1.16 blijft hij ook nog werken.
als ik echter naar PHP7.2.4 en hoger gaat dan gaat het mis dan verdwijnt administrator menu gedeeltelijk
en komen er foutmeldingen
lvda
  1. meer dan een maand geleden
  2. Webhosting
  3. # 8
Geaccepteerde antwoord Pending Moderation
hallo ,
wat gebeurt er als je tijdelijk de standaard template beesz of protostar inschakel.
klopt het dat aan de voorzijde deze fout(zie plaatje staat
Bijlagen
lvda
  1. meer dan een maand geleden
  2. Webhosting
  3. # 9
Geaccepteerde antwoord Pending Moderation
Leen, ik kan in de backend geen andere template selecteren zonder voornoemde foutmeldingen te krijgen en hoe ik dat via de ftp moet doen, daar heb ik niet genoeg php-kennis voor, vrees ik.
Als ik op de frontend kijk, ongeacht welke browser, zie ik vermelde foutmeldingen niet, alleen ééntje van de plugin load module in article, maar dat zal ook wel een update-issue zijn vermoed ik.
  1. meer dan een maand geleden
  2. Webhosting
  3. # 10
Geaccepteerde antwoord Pending Moderation
voorkeur template zou je via phpmyadmin moeten kunnen wijzigen
in het plaatje staat bij mij dus protostar gemerkt met 1 = home voorzijdewebsite
en isis = administrator template 1 en 1
dus kijk of je de verkeerde home template kan uit zetten door die te wijzigen in 0
en protostar aan te zetten
Bijlagen
lvda
  1. meer dan een maand geleden
  2. Webhosting
  3. # 11
Geaccepteerde antwoord Pending Moderation
Een frontend template heeft niets te maken met de werking van de backend. Het kan wel zijn dat je (na een migratie van 2.5?) nog oude backend templates actief hebt staan. Dat zou dit probleem eventueel wel kunnen verklaren.
  1. meer dan een maand geleden
  2. Webhosting
  3. # 12
Geaccepteerde antwoord Pending Moderation
Hoi Margriet, de update gebeurde vanuit Joomla 3.7.5 en als admin-templates staan hathor en isis geïnstalleerd. Voor de frontend zie ik beez3, protostar en rt_chimera (Gantry), waarvan de laatste actief is want ik heb gezien dat die komt vragen naar updates.
  1. meer dan een maand geleden
  2. Webhosting
  3. # 13
Geaccepteerde antwoord Pending Moderation
  • Ga eens via ftp naar mod.jpg
  • Hernoem daar loadmoduleinarticle naar loadmoduleinarticle-old
  • Schoon je cache op van je browser (ctrl+f5) en site.
  • En kijk of de backend dan wel goed werkt en je de eventuele updates wel kunt doen.

Op deze manier kun je uitsluiten of loadmoduleinarticle wel of niet de boosdoender is.

Succes ermee.

Groeten Ron :)
Bijlagen
  1. meer dan een maand geleden
  2. Webhosting
  3. # 14
Hans
Moderator
Geaccepteerde antwoord Pending Moderation
Ik kom op mijn website loadmoduleinarticle niet tegen. Is dit een 3rd party extensie? Is die ook up-to-date?
JDoc-vertaler, JPatch tester, JUG-organisator, moderator
Eigen site: https://www.hierbenikthuis.nl en van mijn loopgroep: https://www.loopgroep-arnhemia.nl
Assistant Team Leader van het Joomla Social Media Team
  1. meer dan een maand geleden
  2. Webhosting
  3. # 15
Geaccepteerde antwoord Pending Moderation
Dag Ron en Hans

Load module in article is inderdaad een 3rd party extension. Ik heb die zonet hernoemd, maar zoals verwacht spelen bepaalde sliders dan niet af. De cache van de site kan ik ook niet legen zonder de vermelde foutmeldingen te krijgen.
Ik begin te denken dat ik best kan voorstellen om een nieuwe website te bouwen.
  1. meer dan een maand geleden
  2. Webhosting
  3. # 16
Geaccepteerde antwoord Pending Moderation
Hallo Marvan,
zit er soms een beveiliging over de website ? het gaat toch om
pcs-online.be

er wordt daar ook een cookie melder gebruikt ? zet die ook eens uit als kan.
weet je zeker dat de database heel is

/administrator/index.php?option=com_installer&view=database

en of staat de log pad wel goed in administrator > Algemene instellingen > tabblad system
en tmp pad bij administrator > Algemene instellingen > tabblad server
lvda
  1. meer dan een maand geleden
  2. Webhosting
  3. # 17
Geaccepteerde antwoord Pending Moderation
Hoi Leen

De website is beveiligd met ssl. Er wordt inderdaad een cookieconsent gebruikt, maar hoe zet ik die uit zonder toegang tot de backend (omwille van de foutmeldingen bij doorklikken)?
De paden staan correct, ik heb voor de veiligheid eerst path.php erop gezet.
  1. meer dan een maand geleden
  2. Webhosting
  3. # 18
Geaccepteerde antwoord Pending Moderation
ik denk niet echt dat dat het is kan ook niet goed zien welke cookieconsent de site gebruikt
het lijkt op iets van Cloudflare nu weet ik niet of de website ook bij hun draai.
zo ja dan zou het me ook niet verbazen waarom update niet goed gaat
ik lees hier het voor het eerst over cloudflare hoe het werkt

maar dan zou hij ook tussen de plugins kunnen staan en dan die hernoemen ook.
ps
maar een vraagje heb je deze site met een akeeba backup geïnstalleerd ?
lvda
  1. meer dan een maand geleden
  2. Webhosting
  3. # 19
Geaccepteerde antwoord Pending Moderation
Dag Leen

Ik zie net in de brondcode dat die cookieconsent inderdaad via Cloudflare loopt.
De backup is niet via Akeeba genomen maar gewoon met een dump van de dbase en de ftp via filezilla.
  1. meer dan een maand geleden
  2. Webhosting
  3. # 20
  • Pagina :
  • 1
  • 2


Er zijn nog geen reacties op dit bericht.
Wees een van de eersten om op dit bericht te reageren!